tp5支持php7.4需要修改

浏览:248 发布日期:2019/12/12 分类:ThinkPHP5专区
PHP7.4不再支持使用大括号访问数组以及字符串的偏移.如果在PHP7.4以后的代码中,还是使用大括号来获取的话,那么就会抛出如下错误信息:Array and string offset access syntax with curly braces is deprecated
因此想让您的TP5支持php7.4则需要修改一处代码
thinkphp\library\think\db\Query.php,TP不同版本对应行数可能不同,如tp5.0.9为370行,TP5.0.24为399行


最佳答案
评论( 相关
后面还有条评论,点击查看>>